Знаете выражение
 

Другие статьи из рубрики «Задачи по программированию»

Я - репетитор по информатике и программированию

Здравствуйте! Меня зовут Александр Георгиевич. Я - профессиональный московский репетитор по информатике, математике, базам данных, алгоритмам и программированию.

Несмотря на то, что вы очень занятой человек я настоятельно рекомендую вам потратить 2-3 минуты и ознакомиться с отзывами клиентов, которые прошли подготовку под моим контролем.

На своих уроках я делаю упор как на практику, так и на теорию. Следовательно, помимо алгоритма вычисления среднего значения элементов массива, я готов вам продемонстрировать абсолютно любой алгоритм, ориентированный на обработку массивов данных.

Прежде чем записаться ко мне на первый пробный урок, вам необходимо выбрать 1 из 144 вариантов нашего будущего взаимовыгодного сотрудничества.

И помните о том, что я достаточно востребованный репетитор, следовательно, количество ученических мест ограниченно. Звоните прямо сейчас, так как завтра свободных мест уже может не быть!

Видеоролик, демонстрирующий алгоритм нахождения среднего значения элементов массива

Алгоритм вычисления среднего значения элементов массива крайне популярен и востребован. Кроме того, что этот алгоритм изучается в школах и вузах, его результаты постоянно окружают нас и в повседневной жизни.

Именно поэтому, я выделил достаточное количество времени из своего плотного графика репетиторских уроков и специально для вас снял мультимедийный ролик, в котором рассказываю принцип его работы.

Реализация алгоритма нахождения среднего значения элементов массива на языке Паскаль

const
  N = 6;
var
  v: array[1..N] of byte;
  s: word;
  i: byte;
begin
  for i := 1 to N do
  begin
    v[i] := random(6) + 1;
    write(v[i]:5);
  end;
  s := 0;
  for i := 1 to N do
    s := s + v[i];
  writeln;
  writeln('Среднее значение элементов массива: ', (s / N):0:2);
end.

Отзывы
моих учеников

Якименко
Александр

 
Я вообще, в школе учусь плоховато и, меня натаскивают родители, заставляют заниматься, но когда занимались с Александром Георгиевичем, то мне нравилось, я начал понимать и начинала появляться уверенность, что я Смогу....

Трунин
Сергей

 
На редкость сильный репетитор, абсолютно компетентен в преподаваемом предмете, знает язык программирования Turbo Pascal просто "насквозь". Было интересно заниматься и очень познавательно, так как в школе мы ничего этого...

Иванцова
Татьяна

 
Никогда не думала, что за 15 дней можно серьезно подготовиться к зачету по MS Excel 2003. С репетитором занимались очень интенсивно и очень много решали заданий. Было интересно и познавательно в целом, но в жизни, я...

Юзов
Артур

 
Я благодарен Александру Георгиевичу за его работу со мной. Теперь чувствую себя уверенно при программирование на языке Паскаль. Если у меня в процессе последующего обучения возникнут какие-то проблемы, я обязательно...
Смотреть все отзывы
 
 
 
 
 
 
Авторизация на сайте
 
 
 
Обнаружили
ошибку на сайте?
Занятия по информатике